Version 2018.2


Substance Painter 2018.2 adds long awaited features such as Subsurface Scattering painting that make texturing even easier than before.

Release date : 2 August 2018

Major Features

Subsurface scattering

Subsurface scattering is now supported in the realtime viewport and with the Iray renderer.
Subsurface scattering is a mechanism of light when penetrating an object or a surface. Instead of being reflected, like with metallic surfaces, a portion of the light is absorbed by the material and then scattered inside. Many materials in real life have subsurface scattering such as skin or wax.

Our Subsurface effect implementation match very closely both real-time implementations from other game engines as well as other offline renderers. Making it very easy to author scattering textures to use in other applications.

Above is an example with the well know Digital Emily 2 asset. Thanks to the USC Institute for Creative Technologies and members of the Wikihuman project for allowing us to demonstrate our renders with the Digital Emily 2 assets.
(Please note this comparison was made under similar but not exact lighting conditions which may explains visual differences.)

To add Subsurface Scattering in a project follow these few steps :

  1. Go to the Display Settings window and activate the Subsurface Scattering setting.
  2. Add a "Scattering" channel in the current texture set
  3. Use a fill layer or paint in white in the new channel to reveal the subsurface effect in the viewport.

A more detailed procedure can be found in the Subsurface Scattering documentation.

In order to support Subsurface Scattering in the realtime viewport the shaders in the projects have to be updated.
For custom shaders please refer to the documentation available in the help menu for to know what has changed in the shader API.

Manipulators for fill layers

Fill layers controls have been improved to offer manipulators. It is now easier to precisely place and control fill projections.

When using the UV projection a manipulator will appear in the 2D View :

  • Clicking outside the manipulator will rotate it.
  • Clicking on the square at the borders will scale/resize it.
  • Clicking inside the manipulator will translate it.
  • Use CTRL to affect multiple corner in symmetry.
  • Use SHIFT to constraint a transformation (translate, rotation or scale).

When using the Tri-Planar projection a manipulator will appear in the 3D View

  • The dotted cube represent the global projection
  • Use the W, E or R keyboard shortcut to switch between the Translate, Rotate and Scale mode.
  • Use the T keyboard shortcut to switch between Local and World orientation for the manipulator.
  • Use SHIFT to constraint the transformation.
  • The Tri-Planar cube projection can also be modified in the advanced fill layer properties :

The contextual toolbar at the top of the viewport will also adapt depending of the current projection mode, offering additional tools and controls :

For more details, see the Fill Layer documentation.

Non-square and non-tilling support for Stencil and Projection tool

The stencil parameter and projection tool have been improved to support non-square resolutions and non-tilling behaviors.
The default parameter is now set to non-tilling by default. This parameter can be changed in the tool properties :

The tilling mode can be set as follow :

  • No Tiling (default)
  • Horizontal Tiling
  • Vertical Tiling
  • H and V Tiling (old behavior)

This new parameter can be saved in a tool or brush preset, making it easy to share with custom content.

  • The projection ratio will also adapt with Substance files that output non-square resolutions. The ratio will be computed directly from the output node.
  • With the projection tool if multiple channels have different ratios, the first ratio found will be applied to all the other channels.

Camera import and management

It is now possible to import custom cameras inside Substance Painter alongside the mesh import.
Cameras can be selected to look through them in the 3D viewport and used to render in Iray.

For more details, see the Camera Management documentation.

To import cameras into a project :

  1. Export the mesh for the project with cameras in the same file (with a supported format such as FBX, Alembic or glTF)
  2. Select the "import cameras" settings in the new project window (or project configuration).
  3. Switch to the desired camera with the dropdown in the viewport or by using the settings in the Display Settings.

The Camera Settings in the Display Settings window have been extended to control the Camera's properties.
It is possible to switch between cameras, see its ratio and lock its properties to avoid modifying it. A restore button can be used to revert the camera to its initial values.

The camera frame (and it's gate) is also taken into account, making it possible to view and paint via a very specific point of view. The frame and gate are displayed over the 3D Viewport and its opacity can be controlled in the Viewport Settings from the Display Settings window :

Layer stack behavior improvements

  • Drag and Drop Materials and Smart Materials onto the ID map :
    The drag and drop of content from the shelf into the viewport has been improved. By pressing CTRL while drag and dropping a material it is now possible to choose the ID color that will be used as a mask.
    A black mask with a color selection effect will be added to the new layer created in the layer stack. If the same material is drag and dropped onto an other ID color, the already existing layer will be updated and the ID colors will be combined..

  • Layer stack drag and drop scroll :
    Dragging layers around the layer stack is now with a small window.
    When a resource or a layer is dragged near the borders of the layer stack window, it will automatically start to scroll its content. 

glTF and Alembic mesh import

New file formats are now supported for importing meshes and creating new projects :

  • glTF : This format was already available when exporting textures and can now be used during the import. If a glTF file contains textures they will be imported and placed inside the layer stack (for the metallic/roughness workflow).
  • Alembic : This format is widely used in the VFX / Animation industry to transfert meshes.

Substance Painter doesn't offer a way to control which frame of animation should be imported at the moment.
This means that when exporting an Alembic file the frame of reference to be used for painting on the asset has to be already set.

Substance integration improvements

The Substance integration inside Substance Painter has been improved with long awaited requests :

  • Visible If :
    The "Visible if" is a great feature of the Substance file format which allows to hide parameters based on conditions.
    This feature provides a more clear list of parameters and contextual settings, giving overall more easy to use materials and filters.
    For more details see the Substance Designer documentation.
  • Substance Presets
    Substance presets are an easy way to provide advanced tweaks and variations of materials. Many materials on Substance Source have presets, so give it a try !
    If a Substance file contains one or more presets, a new dropdown in the parameter list will be available. Select which preset to apply to update the parameters.
  • Substance Attributes
    Substance attributes are now displayed in the interface, making it easier to retrieve information about a specific file.
    Attributes can be viewed in two different location : above the parameters in the properties window or by right-clicking on an asset in the shelf.
     

New sample project "Jade Toad"

A new sample project named "JadeToad" is now included with Substance Painter. This sample project has the Subsurface Scattering effect enabled by default.
To find the project, use the File > Open Sample... menu entry.

Release Notes

2018.2.3

(Released September 25, 2018)

Fixed:

  • [2D View] 2D View is broken with some meshes when creating a new project
  • [Crash] Switching from UV projection to tri-planar projection leads to a crash
  • [RayCollider] Multiple crashes due to "RayCollider"
  • [Tool] Switching layers lose the modified brush properties
  • Brush settings are reseted when switching to the eraser

Known issues:

  • Computation freeze on AMD VEGA GPUs
  • Huion tablet issue with shortcuts on Windows OS


2018.2.2

(Released September 11, 2018)

Added:

  • Summary: Hotfix with content update, new scripting functionalities and being able to disable the auto update
  • [Content][Shelf] Add a Skin shelf preset
  • [Content][shelf] Conversion of 19 skin normals into materials for subsurface scattering
  • [Scripting] Create a project template from an open project
  • [Scripting] Get/Set export settings of an opened project
  • [Updates] Be able to disable the auto update pop-up from settings and environment variable
  • [Updates] Have a not display until next version on the maintenance outdated pop-up

Fixed:

  • [Camera] Wrong zoom by switching from orthographic to perspective
  • [Display] Some maps are displayed in linear instead of sRGB
  • [Viewports] Mesh focus does not behave properly
  • [2D View] Project with broken camera has disappearing UVs Shells
  • [SSS][Tooltip] subsurface scattering tooltips appear in the log
  • Some projects cannot be opened in 2018.2 and error message can't save a null substance package
  • [Mask] Paint tool color can be stuck in some cases when working in a mask
  • [Material] Maps not appearing in specific situations
  • [Proj][Tools] Manipulator active with a generator
  • [Substance] Missing Substance groups of parameters
  • [Scripting] Incorrect software name in documentation
  • [UDIMs] No information in log about UVs shells on multiple UVs tiles

Known issues:

  • Computation freeze on AMD VEGA GPUs
  • Huion tablet issue with shortcuts on Windows OS

2018.2.1

(Released August 3, 2018)

Fixed:

  • Missing subsurface scattering shader parameters from upgrading projects

Known Issues:

  • Computation freeze on AMD VEGA GPUs
  • Huion tablet issue with shortcuts on Windows OS

2018.2

(Released August 2, 2018)

Added:

  • Summary: Summer release, subsurface scattering Support, projection and fill improvements, camera import and selection, Alembic/glTF support, drag and drop on ID map, improved Substance format support and new content
  • [SSS][Viewport][Iray] Generic subsurface scattering
  • [SSS] Sync MDL and subsurface scattering parameters
  • [SSS] Added a new grayscale channel named "Scattering"
  • [SSS][Shader Settings] Scattering type parameter for subsurface scattering (skin or translucent)
  • [SSS][Shader Settings] Scattering scale parameter for subsurface scattering
  • [SSS][Shader Settings] Scattering color parameter for subsurface scattering
  • [SSS][Display Settings] Scattering Sample count for subsurface scattering
  • [Shader][Iray] Integrate subsurface scattering MDL for Iray
  • [Shader] Shader update via the resource updater
  • [Shader] Update change log API and documentation
  • [Tool Properties][Proj] New parameters for the triplanar projection
  • [Viewport][Proj] Control Fill Layer properties in 3D view directly with manipulators (triplanar projection)
  • [Shortcuts][Proj] New shortcuts Q, W, E, R, T for triplanar projection manipulators
  • [Viewport][Proj] Control Fill Layer properties in 2D view directly with manipulators (UV projection)
  • [Shortcuts][Proj] New shortcut Q for UV projection manipulators
  • [Contextual Toolbar][Proj] Control triplanar projection manipulators
  • [Contextual Toolbar][Proj] Control UV projection manipulators
  • [Tool Properties] Disable texture tiling with projection and Stencil tool
  • [Stencil] Use non-squared images with the projection tool/stencil
  • [Stencil] Allow control of tiling mode in Properties window
  • [Stencil] Zoom is not centered on a non-tiling stencil
  • [Cameras] Import cameras from Maya, Max, Blender, Modo, DAE
  • [Cameras][Viewport] Select and control imported cameras in viewport
  • [Cameras][Iray] Select and control imported cameras in Iray
  • [Cameras][UI][New project][Project configuration] "Import cameras" is checked by default
  • [Cameras][Shortcuts] Add shortcuts "<" and ">" to switch between cameras
  • [Cameras][Viewport] Add frame in viewport
  • [Cameras][Viewport Settings] Control of frame opacity
  • [Cameras][Camera Settings] Maximum focal length at 500mm
  • [Cameras][Camera Settings] Expose ratio
  • [Cameras][Camera Settings] Add a lock option
  • [Cameras][Camera Settings] Add a restore option
  • [Cameras][Camera Settings] Add focus distance attribute
  • [glTF] Import of a glTF file
  • [glTF] Import ambient occlusion map
  • [Alembic] Import Alembic 1 frame with static geometry
  • [Shelf] Drag and drop materials directly onto the mesh using ID maps with a modifier (CTRL/Command)
  • [Layer Stack] Automatic ID mask creation with drag and drop of materials on mesh with ID maps
  • [Layer Stack] Automatic scroll of layers with drag and drop across the layer stack
  • [UI][Tool Properties] Expose Substance's preset
  • [UI][Help menu] Improvement of the Help menu
  • [UI][New Project][Project Configuration] Reorganization of the window
  • [UI][New Project][Project Configuration] Replace "Mesh" term by "File"
  • [UI][Substance] Display Substance attributes in UI
  • [Shortcuts] "F4" switches between 2D and 3D view
  • [Shortcuts] New shortcuts for toggle stencil "N" and quick mask "U"
  • [Substance integration] Take into account 'visible if' statements in the Substance parameters
  • [Viewport] Shadows not forced to be computed after camera move
  • [Content] Update MeetMat with imported cameras
  • [Content] Add a sample with subsurface scattering enabled - JadeToad
  • [Content] Add a new PBR project template with subsurface scattering enabled
  • [Content] Updated export presets to add new Scattering channel
  • [Content][Shelf] Added subsurface scattering support for: pbr-metal-rough, pbr-metal-rough-alpha-test, pbr-coated, pbr-spec-gloss
  • [Content][Shelf] Added Scattering channel to 5 smart materials (marbles and skins)
  • [Content][Shelf] 1 new jade Material
  • [Content][Shelf] 1 new wax Material

Fixed:

  • [CMD] Different results using same command line with different versions
  • [TDR] If TdrLevel is set up you don't have any errors in your log
  • [Baker] Ambient occlusion map is flipped
  • [ID Map] Crashing when picking outside of 0-1 range
  • [Iray] Crash when switching texture sets and going back to Paint mode
  • [Viewport] Sync drop areas between viewports for drag and drop
  • [Engine] Moire artifact when tiling fill layers or painting small brush
  • [License] License service bad software version check
  • [License] Rework the way we handle authentication
  • [API] Call the `onNewProjectCreated` scripting API event even when creating with a template
  • [Shader] Compiled shader is not loaded from cache when shader file doesn't compile
  • [Shelf] Exporting HDR file from the shelf will output a file with clamped values
  • [Export] EXR export clamps RGB color values between 0-1
  • [Content] Procedural noise "3D Perlin Noise Fractal" is pixelated

Known Issues:

  • Computation freeze on AMD VEGA GPUs
  • Huion tablet issue with shortcuts on Windows OS